<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head>
<meta charset="UTF-8"/>
<title>Who is AD Diggs, Moniece Slaughter&#039;s girlfriend on Love &amp; Hip Hop Hollywood?</title><meta name="viewport" content="width=device-width, initial-scale=1"/>
<meta name="news_keywords" content="Love & Hip Hop Hollywood, AD Diggs, Moniece Slaughter, Moniece Slaughter girlfriend, Moniece Slaughter lesbian, Love & Hip Hop Hollywood premiere">
 
<meta property="og:image:width" content="800"/>
<meta property="og:image:height" content="432"/>
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Who is AD Diggs, Moniece Slaughter’s girlfriend on Love & Hip Hop Hollywood?">
<meta name="twitter:description" content="Moniece Slaughter has a new lover in her life on Love &amp;amp; Hip Hop Hollywood, and this time it's a woman!    Moniece's relationship with Annette Diggs — who goes by the name AD Diggs for short">
<meta name="twitter:image" content="http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood.jpg">
<meta name="twitter:site" content="@monstersandcrit">
<meta name="twitter:creator" content="@roamingbeetle">
 
 
<meta name="description" content="Moniece Slaughter is looking happier than ever in her lesbian relationship on Love &amp; Hip Hop Hollywood, but who is her new boo AD Diggs?"/>
<link rel="canonical" href="http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Who is AD Diggs, Moniece Slaughter&#039;s girlfriend on Love &amp; Hip Hop Hollywood?"/>
<meta property="og:description" content="Moniece Slaughter is looking happier than ever in her lesbian relationship on Love &amp; Hip Hop Hollywood, but who is her new boo AD Diggs?"/>
<meta property="og:url" content="http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/"/>
<meta property="og:site_name" content="Monsters and Critics"/>
<meta property="article:publisher" content="https://www.facebook.com/monsterscritics"/>
<meta property="article:tag" content="AD Diggs"/>
<meta property="article:tag" content="Love &amp; Hip Hop: Hollywood"/>
<meta property="article:tag" content="Moniece Slaughter"/>
<meta property="article:section" content="Smallscreen"/>
<meta property="article:published_time" content="2017-07-25T12:51:52+01:00"/>
<meta property="fb:app_id" content="220249472958"/>
<meta property="og:image" content="http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood.jpg"/>
<meta property="og:image:width" content="800"/>
<meta property="og:image:height" content="432"/>
 
<link rel='dns-prefetch' href='//app.newsatme.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Monsters and Critics &raquo; Feed" href="http://www.monstersandcritics.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Monsters and Critics &raquo; Comments Feed" href="http://www.monstersandcritics.com/comments/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.monstersandcritics.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='news-pro-theme-css' href='http://cdn.monstersandcritics.com/wp-content/themes/news-pro/style.css?ver=3.0.0' type='text/css' media='all'/>
<link rel='stylesheet' id='mashsb-styles-css' href='http://cdn.monstersandcritics.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css?ver=3.4.2' type='text/css' media='all'/>
<style id='mashsb-styles-inline-css' type='text/css'>.mashsb-count{color:#cccccc;}@media only screen and (min-width:568px){.mashsb-buttons a{min-width:177px;}}</style>
<link rel='stylesheet' id='mashfs-css' href='http://cdn.monstersandcritics.com/wp-content/plugins/mashshare-floating-sidebar/assets/css/mashfs.min.css?ver=1.2.9' type='text/css' media='all'/>
<link rel='stylesheet' id='mashnet-styles-css' href='http://cdn.monstersandcritics.com/wp-content/plugins/mashshare-networks/assets/css/mashnet.min.css?ver=2.4.2' type='text/css' media='all'/>
<link rel='stylesheet' id='mashresp-styles-css' href='http://cdn.monstersandcritics.com/wp-content/plugins/mashshare-responsive/assets/css/mashresp.min.css?ver=2.0.7' type='text/css' media='all'/>
<style id='mashresp-styles-inline-css' type='text/css'>@media only screen and (max-width: 568px) {.mashsb-box .mashsb-count{display:none;}}@media only screen and (max-width: 568px){.mashsb-buttons a{width:41px;}}@media only screen and (max-width: 568px){[class^="mashicon-"] .text,[class*=" mashicon-"] .text{display:none;}}</style>
<link rel='stylesheet' id='mashbar-css' href='http://cdn.monstersandcritics.com/wp-content/plugins/mashshare-sharebar/assets/css/mashbar.min.css?ver=4.8' type='text/css' media='all'/>
<style id='mashbar-inline-css' type='text/css'>#mashbar-header{top:0px;}#mashbar-header{background-color:#383e4d;z-index:999999;}@media (min-width: 630px) {#mashbar-header .mashbar-inner{max-width:960px;margin:0 auto;}}</style>
<link rel='stylesheet' id='custom-css-css' href='http://cdn.monstersandcritics.com/wp-content/themes/news-pro/style_custom.css?ver=2.5.2' type='text/css' media='all'/>
<link rel='stylesheet' id='mediaelement-css' href='http://cdn.monstersandcritics.com/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.22.0' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-mediaelement-css' href='http://cdn.monstersandcritics.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.8' type='text/css' media='all'/>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"0","round_shares":"","animate_shares":"0","dynamic_buttons":"0","share_url":"http:\/\/www.monstersandcritics.com\/smallscreen\/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood\/","title":"Who+is+AD+Diggs%2C+Moniece+Slaughter%E2%80%99s+girlfriend+on+Love+%26+Hip+Hop+Hollywood%3F","image":"http:\/\/www.monstersandcritics.com\/wp-content\/uploads\/2017\/07\/ad-diggs-moniece-slaughter-love-hip-hop-hollywood.jpg","desc":"Moniece Slaughter has a new lover in her life on Love & Hip Hop Hollywood, and this time it's a woman!\r\n\r\nMoniece's relationship with Annette Diggs \u2014 who goes by the name AD Diggs for short \u2026","hashtag":"monstersandcrit","subscribe":"content","subscribe_url":"","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"1"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.js?ver=3.4.2'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.4.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashfs = {"mobile_width":"460"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/mashshare-floating-sidebar/assets/js/mashfs.min.js?ver=1.2.9'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/mashshare-google-analytics/assets/js/mashga.min.js?ver=1.0.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashnet = {"body":"Check out this article: ","subject":"Check out this site","pinterest_select":"0"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/mashshare-networks/assets/js/mashnet.min.js?ver=2.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashbar = {"scroll_distance":"100","mobile_only":"","mobile":"1"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/mashshare-sharebar/assets/js/mashbar.min.js?ver=1.3.9'></script>
<!--[if lt IE 9]>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://www.monstersandcritics.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.monstersandcritics.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://cdn.monstersandcritics.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.8"/>
<link rel='shortlink' href='http://www.monstersandcritics.com/?p=629303'/>
<link rel="alternate" type="application/json+oembed" href="http://www.monstersandcritics.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.monstersandcritics.com%2Fsmallscreen%2Fwho-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.monstersandcritics.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.monstersandcritics.com%2Fsmallscreen%2Fwho-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood%2F&#038;format=xml"/>
 
<meta property="fb:pages" content="193326863118"/><script>advanced_ads_sticky_ads = new Array();</script><style type='text/css'>img#wpstats{display:none}</style><script data-cfasync='true' type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-345617-1']);
  _gaq.push(['_setDomainName', 'monstersandcritics.com']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-345617-46', 'auto');
  ga('send', 'pageview');

</script>
<style type="text/css">.site-title a{background:url(http://cdn.monstersandcritics.com/wp-content/uploads/2016/08/mc-logo-blue.png) no-repeat!important;}</style>
 
<script type="text/javascript">

					var sampling_active = 1;
					var sampling_rate   = 100;
					var do_request = false;

					if ( !sampling_active ) {
						do_request = true;
					} else {
						var num = Math.floor(Math.random() * sampling_rate) + 1;
						do_request = ( 1 === num );
					}

					if ( do_request ) {

						/* Create XMLHttpRequest object and set variables */
						var xhr = ( window.XMLHttpRequest )
						  ? new XMLHttpRequest()
						  : new ActiveXObject( "Microsoft.XMLHTTP" ),
						url = 'http://www.monstersandcritics.com/wp-admin/admin-ajax.php',
						params = 'action=update_views_ajax&token=26deb8414f&wpp_id=629303';
						/* Set request method and target URL */
						xhr.open( "POST", url, true );
						/* Set request header */
						xhr.setRequestHeader( "Content-type", "application/x-www-form-urlencoded" );
						/* Hook into onreadystatechange */
						xhr.onreadystatechange = function() {
							if ( 4 === xhr.readyState && 200 === xhr.status ) {
								if ( window.console && window.console.log ) {
									window.console.log( xhr.responseText );
								}
							}
						};
						/* Send request */
						xhr.send( params );

					}

				</script>
 
<style type="text/css" id="custom-background-css">body.custom-background{background-color:#ffffff;}</style>
<link rel="amphtml" href="http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/amp/"/><link rel="icon" href="http://cdn.monstersandcritics.com/wp-content/uploads/2016/11/cropped-M_C_Web_600pixel_72dpi_MC_layered-32x32.jpg" sizes="32x32"/>
<link rel="icon" href="http://cdn.monstersandcritics.com/wp-content/uploads/2016/11/cropped-M_C_Web_600pixel_72dpi_MC_layered-192x192.jpg" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="http://cdn.monstersandcritics.com/wp-content/uploads/2016/11/cropped-M_C_Web_600pixel_72dpi_MC_layered-180x180.jpg"/>
<meta name="msapplication-TileImage" content="http://cdn.monstersandcritics.com/wp-content/uploads/2016/11/cropped-M_C_Web_600pixel_72dpi_MC_layered-270x270.jpg"/>
</head>
<body class="post-template-default single single-post postid-629303 single-format-standard custom-background desktop chrome custom-header header-image header-full-width content-sidebar news-pro-blue" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><div style="float:left;"><a href="http://monstersandcritics.com"><img width=“330px" height="40px" alt="Monsters and Critics" src="http://cdn.monstersandcritics.com/wp-content/uploads/2016/08/monsters-critics-logo-new.png"></a></div>

<div class="new_menus notmobile" style=""><ul><li><a href="http://www.monstersandcritics.com/smallscreen/">TV</a></li> <li><a href="http://www.monstersandcritics.com/movies/">MOVIES</a></li> <li><a href="http://www.monstersandcritics.com/top-tens/">TOP TENS</a></li> <li><a href="http://www.monstersandcritics.com/music/">MUSIC</a></li> <li><a href="http://www.monstersandcritics.com/lifestyle/">LIFESTYLE</a></li></ul></div></div>
</div></header><div class="site-container2">
<div class="site-inner">
<div class="mobileOnly">
<a href="http://www.monstersandcritics.com/smallscreen/">TV stories</a> - <a href="http://www.monstersandcritics.com/tv-series/">TV series</a> - <a href="http://www.monstersandcritics.com/movies/">Movies</a> - <a href="http://www.monstersandcritics.com/top-tens/">Top 10s</a>
</div>
<div class="center_content" style="overflow:auto;">


<div style="text-align: center; " id="monst-1298921547"><!--noptimize--><script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "970x250,728x90";
    e9.noAd = 1;
//--></script>
<script type="text/javascript" src="http://tags.expo9.exponential.com/tags/monstersandcriticscom/UK/tags.js"></script><!--/noptimize--></div>
 
</div><div class="content-sidebar-wrap"><main class="content"><article class="post-629303 post type-post status-publish format-standard has-post-thumbnail category-smallscreen tag-ad-diggs tag-love-hip-hop-hollywood tag-moniece-slaughter entry gs-1 gs-odd gs-even gs-featured-content-entry" itemscope itemtype="https://schema.org/CreativeWork">
<div class="post_title_box"><h1>Who is AD Diggs, Moniece Slaughter&#8217;s girlfriend on Love &#038; Hip Hop Hollywood?</h1></div>

    <header class="entry-header"><div style="overflow:auto;"><div style="float:left;"><span style="font-size:14px;">25th July 2017 by <a href="http://www.monstersandcritics.com/author/julian-cheatle/" title="Posts by Julian Cheatle" rel="author">Julian Cheatle</a></span></div>
<div style="clear:both;">

<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-buttons"><a  class="mashicon-facebook mash-large mash-nomargin mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.monstersandcritics.com%2Fsmallscreen%2Fwho-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share&nbsp;with&nbsp;friends</span></a><a  class="mashicon-twitter mash-large mash-nomargin mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Who%20is%20AD%20Diggs%2C%20Moniece%20Slaughter%E2%80%99s%20girlfriend%20on%20Love%20%26%20Hip%20Hop%20Hollywood%3F&url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/&via=monstersandcrit" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><div class="secondary-shares" style="display:none;"><a  class="mashicon-google mash-large mash-nomargin mashsb-noshadow" href="https://plus.google.com/share?text=Who+is+AD+Diggs%2C+Moniece+Slaughter%E2%80%99s+girlfriend+on+Love+%26+Hip+Hop+Hollywood%3F&amp;url=http%3A%2F%2Fwww.monstersandcritics.com%2Fsmallscreen%2Fwho-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Google</span></a><a style="display:none;" class="mashicon-whatsapp mash-large mash-nomargin mashsb-noshadow" href="whatsapp://send?text=Who%20is%20AD%20Diggs%2C%20Moniece%20Slaughter%E2%80%99s%20girlfriend%20on%20Love%20%26%20Hip%20Hop%20Hollywood%3F%20http%3A%2F%2Fwww.monstersandcritics.com%2Fsmallscreen%2Fwho-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Whatsapp</span></a><a  class="mashicon-stumbleupon mash-large mash-nomargin mashsb-noshadow" href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.monstersandcritics.com%2Fsmallscreen%2Fwho-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Stumbleupon</span></a><a class="mashicon-mail mash-large mash-nomargin mashsb-noshadow" href="/cdn-cgi/l/email-protection#fdc28e889f97989e89c0be95989e96d8cfcd928889d8cfcd8995948ed8cfcd8e948998db9c908dc69f929984c0be95989e96d8cfcd928889d8cfcd8995948ed8cfcd9c8f89949e9198d8cebcd8cfcd9589898dd8cebcd8cfbbd8cfbb8a8a8ad39092938e89988f8e9c93999e8f9489949e8ed39e9290d8cfbb8e909c91918e9e8f989893d8cfbb8a9592d0948ed09c99d099949a9a8ed090929394989e98d08e919c889a9589988f8ed09a948f919b8f94989399d09293d091928b98d095948dd095928dd095929191848a929299d8cfbb" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Mail</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div></div>
                    <div style="clear:both;"></div><div class="mashsb-toggle-container"></div></aside>
            <!-- Share buttons made by mashshare.net - Version: 3.4.2--></div></header><div class="entry-content" itemprop="text"><div id="attachment_629321" style="width: 810px" class="wp-caption aligncenter"><img class="size-full wp-image-629321" src="http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood.jpg" alt="AD Diggs sitting behind Moniece Slaughter on the Love &amp; Hip Hop: Hollywood Season 3 premiere" width="800" height="432" srcset="http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood.jpg 800w, http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood-300x162.jpg 300w, http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood-768x415.jpg 768w, http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood-348x188.jpg 348w, http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood-270x146.jpg 270w, http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood-740x400.jpg 740w, http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood-444x240.jpg 444w, http://cdn.monstersandcritics.com/wp-content/uploads/2017/07/ad-diggs-moniece-slaughter-love-hip-hop-hollywood-185x100.jpg 185w" sizes="(max-width: 800px) 100vw, 800px"><p class="wp-caption-text">AD Diggs with Moniece Slaughter on Love &amp; Hip Hop Hollywood Season 3</p></div>
<p>Moniece Slaughter has a new lover in her life on Love &amp; Hip Hop Hollywood, and this time it’s a woman!</p>
<p>Moniece’s relationship with Annette Diggs — who goes by the name AD Diggs for short — comes after she previously dated Rich Dollaz and Lil Fizz, the father of her son Kamron David.</p>
<p>But who is AD, and what does she do for a living?</p><div class="monst-desktop-ad-1-top adBackground" style="text-align: center; " id="monst-1389735949"><!--noptimize--><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><!-- M&C Desktop All Articles Top --><style>
.adsenseDesktop { width: 250px; height: 250px; }
@media(min-width: 400px) { .adsenseDesktop { width: 300px; height: 250px; } }
@media(min-width: 500px) { .adsenseDesktop { width: 336px; height: 280px; } }
</style><ins class="adsbygoogle adsenseDesktop" style="display:inline-block" data-ad-client="ca-pub-3708278364070344" data-ad-slot="8684751256"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><!--/noptimize--></div>
<p>The 34-year-old, who has both Italian and Puerto Rican heritage, is originally from Brooklyn, New York, but now lives in Los Angeles.</p>
<p>She’s an entrepreneur, the founder of DiggTheKicks, a sneaker store based in Rancho Cucamonga, CA.</p>
<p>The firm sells “classic collectibles and on trend sneakers” with affordable pricing.</p>
<p>AD says the brand is “for sneaker heads” and was inspired by her decades-long love of sneakers, which began when she was a youngster growing up playing and watching basketball.</p>
<p>Annette goes by the name <a href="https://www.instagram.com/diggthekicks/">@diggthekicks</a> on Instagram, where she poses a selection of pics and videos of what she’s been getting up to along with some inspirational messages.</p>
<p>Her footwear store also has its own Instagram page <a href="https://www.instagram.com/d.t.k_diggthekicks/">@d.t.k_diggthekicks</a>, with an online shop also soon set to launch <a href="http://diggthekicksdtk.com/">on the firm’s website</a>.</p>
<p>AD says she generally likes to stay clear of drama and pettiness, but she agreed to take part on Love &amp; Hip Hop Hollywood because it was a challenge, and gives her a chance to be a role model for the LGBTQ community.</p>
<p>Moniece has said that her son Kamron David’s father Lil Fizz is “really ok” with her and AD’s relationship because Kamron and AD have a good bond and are like “two peas in a pod”.</p>
<p>She added: “I think he’s more accepting because it’s not a man.”</p>
<div class="jetpack-video-wrapper"><iframe width="800" height="450" src="https://www.youtube.com/embed/ppXOImRj85g?feature=oembed" frameborder="0" allowfullscreen></iframe></div>
<p><em>Love &amp; Hip Hop Hollywood airs Mondays at 8/7c on VH1.</em></p>
<div id="NamForm" data-id="629303" data-title="Who is AD Diggs, Moniece Slaughter's girlfriend on Love &amp; Hip Hop Hollywood?" data-tags="AD Diggs,Love &amp;amp; Hip Hop: Hollywood,Moniece Slaughter" data-site-id="2003" data-url="http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/"></div>
</div> 
		

	
		<div class="notmobile"><p>Got something to say about this? <a href="#comments">Tell us in the comments!</a></p></div>
<div class="center_content">
You may also like

<div id="contentad326073"></div>
<script type="text/javascript">
    (function(d) {
        var params =
        {
            id: "382f7b0a-53fb-441a-a7f6-c404463505ec",
            d:  "bW9uc3RlcnNhbmRjcml0aWNzLmNvbQ==",
            wid: "326073",
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad326073").appendChild(s);
    })(document);
</script>
                    
                    
<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-buttons"><a  class="mashicon-facebook mash-large mash-nomargin mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.monstersandcritics.com%2Fsmallscreen%2Fwho-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share&nbsp;with&nbsp;friends</span></a><a  class="mashicon-twitter mash-large mash-nomargin mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Who%20is%20AD%20Diggs%2C%20Moniece%20Slaughter%E2%80%99s%20girlfriend%20on%20Love%20%26%20Hip%20Hop%20Hollywood%3F&url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/&via=monstersandcrit" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><div class="secondary-shares" style="display:none;"><a  class="mashicon-google mash-large mash-nomargin mashsb-noshadow" href="https://plus.google.com/share?text=Who+is+AD+Diggs%2C+Moniece+Slaughter%E2%80%99s+girlfriend+on+Love+%26+Hip+Hop+Hollywood%3F&amp;url=http%3A%2F%2Fwww.monstersandcritics.com%2Fsmallscreen%2Fwho-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Google</span></a><a style="display:none;" class="mashicon-whatsapp mash-large mash-nomargin mashsb-noshadow" href="whatsapp://send?text=Who%20is%20AD%20Diggs%2C%20Moniece%20Slaughter%E2%80%99s%20girlfriend%20on%20Love%20%26%20Hip%20Hop%20Hollywood%3F%20http%3A%2F%2Fwww.monstersandcritics.com%2Fsmallscreen%2Fwho-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Whatsapp</span></a><a  class="mashicon-stumbleupon mash-large mash-nomargin mashsb-noshadow" href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.monstersandcritics.com%2Fsmallscreen%2Fwho-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Stumbleupon</span></a><a class="mashicon-mail mash-large mash-nomargin mashsb-noshadow" href="/cdn-cgi/l/email-protection#e7d89492858d828493daa48f82848cc2d5d7889293c2d5d7938f8e94c2d5d7948e9382c1868a97dc8588839edaa48f82848cc2d5d7889293c2d5d7938f8e94c2d5d78695938e848b82c2d4a6c2d5d78f939397c2d4a6c2d5a1c2d5a1909090c98a8889949382959486898384958e938e8494c984888ac2d5a1948a868b8b948495828289c2d5a1908f88ca8e94ca8683ca838e808094ca8a88898e828482ca948b8692808f93829594ca808e958b81958e828983ca8889ca8b889182ca8f8e97ca8f8897ca8f888b8b9e90888883c2d5a1" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Mail</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div></div>
                    <div style="clear:both;"></div><div class="mashsb-toggle-container"></div></aside>
            <!-- Share buttons made by mashshare.net - Version: 3.4.2-->
                                <div id="comments" ></div>
                                
<div class="fb-comments" data-href="http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" data-numposts="5"></div>        
</div>


	

<footer class="entry-footer"></article><div class="after-entry" class="widget-area"><section id="text-99" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"></div>
		</div></section>
</div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-19" class="widget widget_search"><div class="widget-wrap">
                <form method="get" class="searchform search-form" action="http://www.monstersandcritics.com/search/" >
                
                <input type="text" value="Search M&amp;C..." name="q" class="s search-input" onfocus="if (this.value == 'Search M&amp;C...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search M&amp;C...';}" />
                <input type="submit" class="searchsubmit search-submit" value="Search" />
                </form>
                </div></section>
<section class="widget monst-widget"><div class="widget-wrap"><!--noptimize--><div class="center_content"><script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "120x600,300x600,160x600";
    e9.noAd = 1;
//--></script>
<script type="text/javascript" src="http://tags.expo9.exponential.com/tags/monstersandcriticscom/UK/tags.js"></script>
</div><!--/noptimize--></div></section>
<section id="execphp-30" class="widget widget_execphp"><div class="widget-wrap">			<div class="execphpwidget"><div class="notmobile" style="margin: 0 0 3px 0;max-width:306px;background-color:#383e4d;"><span style="padding:px;text-align:center;background-color:#383e4d;color:white;">DON'T MISS</span></div>
<div style="max-width:310px; margin:auto;">
<div id='jp-relatedposts' class='jp-relatedposts' >
	
</div></div>
<div class="center_content">
<script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "300x250,336x280";
    e9.noAd = 1;
//--></script>
<script type="text/javascript" src="http://tags.expo9.exponential.com/tags/monstersandcriticscom/UK/tags.js"></script>
</div></div>
		</div></section>
</aside></div></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="pages-2" class="widget widget_pages"><div class="widget-wrap"><h4 class="widget-title widgettitle">Pages</h4>
		<ul>
			<li class="page_item page-item-3978"><a href="http://www.monstersandcritics.com/monsters-critics/">About Monsters and Critics</a></li>
<li class="page_item page-item-166625"><a href="http://www.monstersandcritics.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-13291"><a href="http://www.monstersandcritics.com/privacy/">Privacy</a></li>
<li class="page_item page-item-566013"><a href="http://www.monstersandcritics.com/team-members/">Team Members</a></li>
<li class="page_item page-item-591729"><a href="http://www.monstersandcritics.com/tv-series/">TV Series</a></li>
		</ul>
		</div></section>
</div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap">  <div class="footer_content">
<p>&copy; Copyright 2004 - 2017 Monsters and Critics &middot; All Rights Reserved &middot; All logos &amp; trademarks belong to their respective owners&middot; All images are used with permission or licensed.</p>

</div></div>


</div></footer></div><script type="text/html" id="tmpl-wp-playlist-current-item">
	<# if ( data.image ) { #>
	<img src="{{ data.thumb.src }}" alt="" />
	<# } #>
	<div class="wp-playlist-caption">
		<span class="wp-playlist-item-meta wp-playlist-item-title">&#8220;{{ data.title }}&#8221;</span>
		<# if ( data.meta.album ) { #><span class="wp-playlist-item-meta wp-playlist-item-album">{{ data.meta.album }}</span><# } #>
		<# if ( data.meta.artist ) { #><span class="wp-playlist-item-meta wp-playlist-item-artist">{{ data.meta.artist }}</span><# } #>
	</div>
</script>
<script type="text/html" id="tmpl-wp-playlist-item">
	<div class="wp-playlist-item">
		<a class="wp-playlist-caption" href="{{ data.src }}">
			{{ data.index ? ( data.index + '. ' ) : '' }}
			<# if ( data.caption ) { #>
				{{ data.caption }}
			<# } else { #>
				<span class="wp-playlist-item-title">&#8220;{{{ data.title }}}&#8221;</span>
				<# if ( data.artists && data.meta.artist ) { #>
				<span class="wp-playlist-item-artist"> &mdash; {{ data.meta.artist }}</span>
				<# } #>
			<# } #>
		</a>
		<# if ( data.meta.length_formatted ) { #>
		<div class="wp-playlist-item-length">{{ data.meta.length_formatted }}</div>
		<# } #>
	</div>
</script>
<!--[if IE 7]><style>
.wpv-pagination { *zoom: 1; }
</style><![endif]-->
<aside id="mashfs-main" class="mashfs-hide mashfs-left" style="background-color: transparent; margin-left:0px; margin-right:0px;"><div class="mashfs-buttons"><a href="http://www.facebook.com/sharer.php?u=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" class="mashicon-facebook mashfs-popup-share" style="margin-bottom: 0px;" rel="external nofollow"><span class="icon"></span></a><a href="https://twitter.com/intent/tweet?text=Who+is+AD+Diggs%2C+Moniece+Slaughter%E2%80%99s+girlfriend+on+Love+%26+Hip+Hop+Hollywood%3F&via=monstersandcrit&url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" class="mashicon-twitter mashfs-popup-share" style="margin-bottom: 0px;" rel="external nofollow"><span class="icon"></span></a><a href="https://plus.google.com/share?text=Who%20is%20AD%20Diggs%2C%20Moniece%20Slaughter%26%23039%3Bs%20girlfriend%20on%20Love%20%26%20Hip%20Hop%20Hollywood%3F&url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" class="mashicon-google mashfs-popup-share" style="margin-bottom: 0px;" rel="external nofollow"><span class="icon"></span></a><a href="whatsapp://send?text=Who%20is%20AD%20Diggs%2C%20Moniece%20Slaughter%26%23039%3Bs%20girlfriend%20on%20Love%20%26%20Hip%20Hop%20Hollywood%3F%20http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" class="mashicon-whatsapp mashfs-popup-share" style="margin-bottom: 0px;" rel="external nofollow"><span class="icon"></span></a><a data-mashsb-url="https://pinterest.com/pin/create/button/?url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/&media=http%3A%2F%2Fwww.monstersandcritics.com%2Fwp-content%2Fuploads%2F2017%2F07%2Fad-diggs-moniece-slaughter-love-hip-hop-hollywood.jpg&description=Moniece+Slaughter+has+a+new+lover+in+her+life+on+Love+%26amp%3Bamp%3B+Hip+Hop+Hollywood%2C+and+this+time+it%27s+a+woman%21++++Moniece%27s+relationship+with+Annette+Diggs+%E2%80%94+who+goes+by+the+name+AD+Diggs+for+short" href="#" class="mashicon-pinterest mashfs-popup-share" style="margin-bottom: 0px;" rel="external nofollow"><span class="icon"></span></a><a href="http://www.reddit.com/submit?url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/&title=Who%20is%20AD%20Diggs%2C%20Moniece%20Slaughter%26%23039%3Bs%20girlfriend%20on%20Love%20%26%20Hip%20Hop%20Hollywood%3F" class="mashicon-reddit mashfs-popup-share" style="margin-bottom: 0px;" rel="external nofollow"><span class="icon"></span></a><a href="http://www.stumbleupon.com/submit?url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" class="mashicon-stumbleupon mashfs-popup-share" style="margin-bottom: 0px;" rel="external nofollow"><span class="icon"></span></a></div></aside><div id="mashbar-header">
                        <div class="mashbar-inner">
                        <div class="mashbar-logo"><a href="/"> 
                        <span class="desktop"><img alt="Logo" src="http://cdn.monstersandcritics.com/wp-content/uploads/2017/03/monsters-critics-logo-new.png"></span>
                        <span class="mobile"><img alt="Mobile Logo" src="http://cdn.monstersandcritics.com/wp-content/uploads/2017/03/littlelogo.png"></span>
                </a></div><aside class="mashsb-container mashbar"><div class="mashsb-box"><div class="mashsb-buttons"><a style="" class="mashicon-facebook" href="http://www.facebook.com/sharer.php?u=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share&nbsp;with&nbsp;friends</span></a><a style="" class="mashicon-twitter" href="https://twitter.com/intent/tweet?text=Who+is+AD+Diggs%2C+Moniece+Slaughter%E2%80%99s+girlfriend+on+Love+%26+Hip+Hop+Hollywood%3F&via=monstersandcrit&url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Twitter</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><div class="secondary-shares" style="display:none;"><a style="" class="mashicon-google" href="https://plus.google.com/share?text=Who is AD Diggs, Moniece Slaughter&#039;s girlfriend on Love &amp; Hip Hop Hollywood?&url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Google</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><a style="display:none;" class="mashicon-whatsapp" href="whatsapp://send?text=Who is AD Diggs, Moniece Slaughter&#039;s girlfriend on Love &amp; Hip Hop Hollywood?%20http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Whatsapp</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><a style="" class="mashicon-reddit" href="http://www.reddit.com/submit?url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/&title=Who is AD Diggs, Moniece Slaughter&#039;s girlfriend on Love &amp; Hip Hop Hollywood?" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Reddit</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><a style="" class="mashicon-stumbleupon" href="http://www.stumbleupon.com/submit?url=http://www.monstersandcritics.com/smallscreen/who-is-ad-diggs-moniece-slaughters-girlfriend-on-love-hip-hop-hollywood/" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Stumbleupon</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><a style="" class="mashicon-mail" href="/cdn-cgi/l/email-protection#cbf4b8bea9a1aea8bff69ca3a4eba2b8eb8a8feb8fa2acacb8e7eb86a4a5a2aea8aeeb98a7aabeaca3bfaeb9ede8fbf8f2f0b8ebaca2b9a7adb9a2aea5afeba4a5eb87a4bdaeebedaaa6bbf0eb83a2bbeb83a4bbeb83a4a7a7b2bca4a4aff4eda9a4afb2f69daeb9b2eef9fba2a5bfaeb9aeb8bfa2a5aceef9fbaab9bfa2a8a7aef1eef9fba3bfbfbbf1e4e4bcbcbce5a6a4a5b8bfaeb9b8aaa5afa8b9a2bfa2a8b8e5a8a4a6e4b8a6aaa7a7b8a8b9aeaea5e4bca3a4e6a2b8e6aaafe6afa2acacb8e6a6a4a5a2aea8aee6b8a7aabeaca3bfaeb9b8e6aca2b9a7adb9a2aea5afe6a4a5e6a7a4bdaee6a3a2bbe6a3a4bbe6a3a4a7a7b2bca4a4afe4" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Mail</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div></div>
                    <div style="clear:both;"></div><div class="mashsb-toggle-container"></div></aside>
                        <!-- Share Bar by mashshare.net - Version: 1.3.9--></div></div><div id="contentad326052"></div>
<script type="text/javascript">
    (function(d) {
        var params =
        {
            id: "a5fc3207-0b1c-4258-9a76-c2d787916745",
            d:  "bW9uc3RlcnNhbmRjcml0aWNzLmNvbQ==",
            wid: "326052",
            exitPopMobile: true,
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad326052").appendChild(s);
    })(document);
</script>
  
<script id="spout-tag-bd4bd22d-88d6-42ab-80a9-22214f6dafd6">
  (function() {
    var r = encodeURIComponent(top.document.referrer.substring(0,250)),
        p = encodeURIComponent(top.document.location.href.substring(0,250)),
        t = Date.now(),
        u = 'bd4bd22d-88d6-42ab-80a9-22214f6dafd6',
        e = document.createElement('script'),
        s = sessionStorage.getItem('spoutable-' + u);
    if (!s) {
      var m = Math.random.bind(Math);
      s = JSON.stringify({ sessionId: [ t, m(), m(), m(), m(), m(), m(), m(), m(), m(), m(), m(), m() ]});
      sessionStorage.setItem('spoutable-' + u, s);
    }
    e.async = true;
    e.src='//s.spoutable.com/s?u='+u+'&s='+encodeURIComponent(s)+'&t='+t+'&r='+r+'&p='+p;
    document.head.appendChild(e);
  })();
</script>


                
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=109251642429";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script><link rel='stylesheet' id='jetpack-responsive-videos-style-css'  href='http://cdn.monstersandcritics.com/wp-content/plugins/jetpack/modules/theme-tools/responsive-videos/responsive-videos.css?ver=4.8' type='text/css' media='all' />
<script type='text/javascript' defer='defer' src='https://app.newsatme.com/assets/namboot.js?ver=4.8' async defer='defer'></script>
<script type='text/javascript' defer='defer' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201730'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/advanced-ads-sticky-ads/public/assets/js/sticky.js?ver=1.1.1'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.0.4'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"en-US","strings":{"Close":"Close","Fullscreen":"Fullscreen","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Download File":"Download File","Download Video":"Download Video","Play":"Play","Pause":"Pause","Captions\/Subtitles":"Captions\/Subtitles","None":"None","Time Slider":"Time Slider","Skip back %1 seconds":"Skip back %1 seconds","Video Player":"Video Player","Audio Player":"Audio Player","Volume Slider":"Volume Slider","Mute Toggle":"Mute Toggle","Unmute":"Unmute","Mute":"Mute","Use Up\/Down Arrow keys to increase or decrease volume.":"Use Up\/Down Arrow keys to increase or decrease volume.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds."}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
var mejsL10n = {"language":"en-US","strings":{"Close":"Close","Fullscreen":"Fullscreen","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Download File":"Download File","Download Video":"Download Video","Play":"Play","Pause":"Pause","Captions\/Subtitles":"Captions\/Subtitles","None":"None","Time Slider":"Time Slider","Skip back %1 seconds":"Skip back %1 seconds","Video Player":"Video Player","Audio Player":"Audio Player","Volume Slider":"Volume Slider","Mute Toggle":"Mute Toggle","Unmute":"Unmute","Mute":"Mute","Use Up\/Down Arrow keys to increase or decrease volume.":"Use Up\/Down Arrow keys to increase or decrease volume.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds."}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=2.22.0'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=4.8'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-includes/js/wp-util.min.js?ver=4.8'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-includes/js/backbone.min.js?ver=1.2.3'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-includes/js/mediaelement/wp-playlist.min.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpv_pagination_local = {"front_ajaxurl":"http:\/\/www.monstersandcritics.com\/wp-admin\/admin-ajax.php","calendar_image":"http:\/\/www.monstersandcritics.com\/wp-content\/plugins\/wp-views\/embedded\/res\/img\/calendar.gif","calendar_text":"Select date","datepicker_min_date":null,"datepicker_max_date":null,"resize_debounce_tolerance":"100","datepicker_style_url":"http:\/\/www.monstersandcritics.com\/wp-content\/plugins\/types\/library\/toolset\/toolset-common\/toolset-forms\/css\/wpt-jquery-ui\/jquery-ui-1.11.4.custom.css"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<script type='text/javascript' defer='defer' src='http://cdn.monstersandcritics.com/wp-content/plugins/jetpack/modules/theme-tools/responsive-videos/responsive-videos.min.js?ver=1.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201730.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.8.2',blog:'62738352',post:'629303',tz:'1',srv:'www.monstersandcritics.com'} ]);
	_stq.push([ 'clickTrackerInit', '62738352', '629303' ]);
</script>
<script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/\>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body></html>

<!-- Dynamic page generated in 0.330 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2017-07-25 12:52:04 -->

<!-- Compression = gzip -->